Composer detected issues in your platform: Your Composer dependencies require a PHP version >= 7.4.0

This article will show how to fix composer dependencies and PHP version issues. 

Common issues:

Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.1.0". You are running 7.4.26. in /Volumes/Files/Sites/lcm/vendor/composer/platform_check.php on line 24

 

You can fix this issue below command,

composer install --ignore-platform-reqs

 

Or, you can also set  "platform-check": false, in composer.json>config

 #add to composer.json > config
"platform-check": false,

Then run the autoload command,

composer autoload-dump

 

I hope, this will fix your problem.

Related Post

Maksud

Maksud

I am a thinker, not a talker.